Showing posts with label load balancing. Show all posts
Showing posts with label load balancing. Show all posts

Tuesday, 9 February 2010

3 Way Load Balancing With DMZ Exceptions

Here is the lab:



Here is the how to:
3 Way Load Balancing With DMZ Exception -Part1
Setup of the Lab in VMware
Setup of Basic BGP


3 Way Load Balancing With DMZ Exception -Part1 from Richard Vimeo on Vimeo.






3 Way Load Balancing With DMZ Exception -Part2

Set up of R1
NAT setup
Setup of Load Balancing
Installing IPtraf


3 Way Load Balancing With DMZ Exception -Part2 from Richard Vimeo on Vimeo.





3 Way Load Balancing With DMZ Exception -Part3

Correcting Some errors
Destination Nat for DMZ
Firewall Setup

3 Way Load Balancing With DMZ Exception -Part3 from Richard Vimeo on Vimeo.





3 Way Load Balancing With DMZ Exception -Part4
Testing Loadbalancing with speedtest.net
Round up


3 Way Load Balancing With DMZ Exception -Part4 from Richard Vimeo on Vimeo.

Monday, 16 November 2009

Load Balancing with Vyatta VC 6

Here is a diagram of the setup, we are dealing with the router to the far left of the diagram "R10" : diagram

This is the video of me configuring load balancing and testing it:

Vyatta Load Balancing from Richard Vimeo on Vimeo.





Here is the configuration:
Setting up the interfaces:
R10:


interfaces {
ethernet eth0 {
address 10.0.0.27/24
description ISP1
}
ethernet eth1 {
address 192.168.0.181/24
description ISP2
}
ethernet eth2 {
address 10.0.10.10/24
description R10TOR1
}
loopback lo {
address 10.10.10.10/32
}

Setting up the IGP:

protocols {
ospf {
area 10 {
network 10.0.10.0/24
network 10.10.10.10/32
}
default-information {
originate {
always
metric-type 2
}
}
}



Setting up Load Balancing

static {
route 0.0.0.0/0 {
next-hop 10.0.0.126 {
}
next-hop 192.168.0.1 {
}
}
}

load-balancing {
wan {
flush-connections
interface-health eth0 {
failure-count 2
nexthop 10.0.0.126
success-count 1
test 10 {
ping
resp-time 5
target 192.168.0.1
}
}
interface-health eth1 {
failure-count 2
nexthop 192.168.0.1
success-count 1
test 10 {
ping
resp-time 5
target 192.168.0.1
}
}
rule 10 {
inbound-interface eth2
interface eth0 {
weight 1
}
interface eth1 {
weight 1
}
protocol all
}
}
}




Good luck and Enjoy!

Friday, 13 November 2009

Testing Vyatta with QoS and Asterisk(Elastix)

Well, we have done something every simular here


However this time we are going all opensource :)

Monday, 28 September 2009

Load Balancing With HSRP

Got a nice simple lab for you today, load balancing with Hot Standby Routing Protocol.

HSRP is designed to increase the redundancy in LAN gateways. It does this by creating a Virtual MAC address and Virtual IP address.
One router of the "group" is elected as the "active" and the other the "standby", therefore once the "active" router, say for example gets accidentally turned off, the "standby" takes over.

Here is the picture of the lab:





Here is the important configuration:
R2

interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.0
duplex auto
speed auto
!This is the virtual ip group 1
standby 1 ip 10.0.0.253
!I want this router to be the active router
standby 1 priority 12
!Take over active when your priority is higher
standby 1 preempt
!Any name here
standby 1 name Load1
!When this interface goes down, decrease my priority by 10
standby 1 track Serial0/0

!This is the virtual ip group 2
standby 2 ip 10.0.0.254
!I want this router to be the standby router
standby 2 priority 11
!Take over active when your priority is higher
standby 2 preempt
!Any name here
standby 2 name Load2
!When this interface goes down, decrease my priority by 10
standby 2 track Serial0/0


R3

interface FastEthernet0/0
ip address 10.0.0.3 255.255.255.0
duplex auto
speed auto
standby 1 ip 10.0.0.253
standby 1 priority 11
standby 1 preempt
standby 1 name Load1
standby 1 track Serial0/0
standby 2 ip 10.0.0.254
standby 2 priority 12
standby 2 preempt
standby 2 name Load2
standby 2 track Serial0/0



Note that for the load balancing to work 50% of the devices have 10.0.0.253 as their default gateway and the other 50% have 10.0.0.254.

Enjoy :)