R1
!
ip multicast-routing
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
interface FastEthernet1/0
description wan
ip address 10.0.12.1 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet2/0
description lan
ip address 192.168.1.1 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 1
network 10.0.12.0 0.0.0.255 area 0
network 10.0.13.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 1
!
!Define this router as a RP
ip pim rp-candidate Loopback0
!
R2
ip multicast-routing
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
!
!
interface FastEthernet1/0
description wan
ip address 10.0.12.2 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet1/1
description lan
ip address 192.168.2.2 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 2
network 10.0.12.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 2
!
!Define router as a Bootstrap Router Candidate
ip pim bsr-candidate Loopback0 0
!
Note:
ip pim bsr-candidate and ip pim rp-candidate can both be added to the same router if you wish. Therefore in this lab we could of defines both on R1 and left R2 with only ip pim sparse on its interfaces.
Here are the batch files used in VLC:
StartMulticast.bat:
"C:\Program Files\VideoLAN\VLC\vlc.exe" -vvv test.m4v :sout=#transcode{vcodec=h264,vb=800,scale=1,acodec=mp4a,ab=128,channels=2,samplerate=44100}:std{access=udp,mux=ts,dst=239.0.0.1:1234} --ttl 12
StartVideo.bat
call "C:\Program Files\VideoLAN\VLC\vlc.exe" -vvv udp://@239.0.0.1:1234
Here is a video of it all working:
Multicast - Streaming Demo from Richard Vimeo on Vimeo.
14 comments:
Hi Richard,
Great Tutorial , I am hoping to set this up myself over the next while for learning purposes.
Kevin
Glad you liked it!
Wow... Amazingly simple. Thanks!
Hi Richard,
Can i Have some tips on implementing multicasting over the DMVPN tunnel if possible.
Arun.
Does this works? If i have sub interfaces, vlan. How do i apply it?
Hi !
Nice Tutorial !
I'm a beginer and i very like this lab .
Can you send me the gns3 file of this lab , please !
hoangnam280890@gmail.com
Amazing lab, Every one likes this kind of post and support..
Good to see it here.. :)
wow, amazing
can u sent me gns3 file of this lab, i really need it!
thank u sir!
wow, amazing
can u sent me gns3 file of this lab, i really need it!
thank u sir!
my email is minhnguyen91mvpn@gmail.com, please sir!
I have a problem in the interface enabled pim gi0/0.40 gi0/0.30.
The multicast server is connected in gi0/0.30.
When I try from a pc in gi0/0.40 not work.
Any help?
Nice tutorial!
Can I have your GNS3 file ? i'm beginner , thank you
hey, I have config like u write but it did not work, can u give me the video, my email is tuananh141296@hotmail.com ! thanks a lot !
Post a Comment